Upgrading flutter_riverpod 0.12 to 0.13
Review needed0.12.4 → 0.13.1+1Deprecated1New2Changed5Fixed3Other1
Review neededUpgrade verdict
1 deprecation.
In plain terms
- Import flutter_riverpod/flutter_riverpod.dart instead of the old all.dart file, which now exposes everything.
Must act 1 item needs code or config changes
Dart SDK requirement changed in 0.13.0-nullsafety.0: >=2.8.0 <3.0.0 → >=2.12.0-0 <3.0.0.
Nothing in this upgrade needs a code or configuration change.
Deprecations to plan for
Deprecated1
Deprecates
import 'flutter_riverpod/all.dart' in favor of flutter_riverpod/flutter_riverpod.dart.flutter_riverpod/all.dartflutter_riverpod/flutter_riverpod.dart