Skip to content

Upgrading flutter_bloc 7 to 8

Breaking7.3.3 → 8.1.6Breaking4New1Changed4Other21

BreakingUpgrade verdict

4 breaking changes.

  • This version requires the newer major version of the underlying bloc package, so existing code may need updates.
  • This version requires the newer bloc 8 pre-release, so code written against bloc 7 may need updates.
  • This version requires the newer, incompatible bloc v8.0.0-dev.3 package, so existing code may need updates.
  • This version requires the newer, incompatible bloc v8.0.0-dev.2 package.
Top 3 of 4 that need code or config changes

Dart SDK requirement changed in 8.1.3: >=2.12.0 <3.0.0 → >=2.12.0 <4.0.0.

Breaking4
Upgrades flutter_bloc to depend on bloc v8.0.0, which is a breaking change.
Upgrades flutter_bloc to depend on bloc v8.0.0-dev.5.
Upgrades flutter_bloc to depend on bloc v8.0.0-dev.3, a breaking change.
Upgrades flutter_bloc to depend on bloc v8.0.0-dev.2, a breaking change.