Upgrading flutter_bloc 1 to 2
Breaking1.0.0 → 2.1.1Breaking1Deprecated2Changed1Fixed1Other3
BreakingUpgrade verdict
1 breaking change.
In plain terms
- This version depends on a new major version of the core bloc package, so code using the old bloc API may need updating.
- The `builder` option on `BlocProvider` is deprecated; use `create` instead.
Must act 2 items need code or config changes
What you must change
Breaking1
Updates to bloc: ^2.0.0, which may require callers to migrate to the bloc 2.0 API.
blocDeprecations to plan for
Deprecated1
Deprecates
builder in BlocProvider in favor of create to align with provider.BlocProviderbuildercreateRepositoryProvider