Upgrading firebase_core 0.7 to 1
Unknown0.7.0 → 1.24.0
Fetching 50 releases from GitHub…0 / 50
UnknownUpgrade verdict
DepDelta is still reading the notes for this range, so breaking changes can't be ruled out yet.
In plain terms
- DepDelta is still reading the release notes in this range, so it can't rule out breaking changes yet.
- This page updates as the notes come in.
Must act Still reading release notes
DepDelta is still reading the release notes in this range. This updates as they come in.
Dart SDK requirement changed in 1.13.0: >=2.1.0 <3.0.0 → >=2.16.0 <3.0.0.
Flutter requirement changed in 1.0.0-1.0.nullsafety.0: >=1.12.13+hotfix.5 <2.0.0 → >=1.12.13+hotfix.5.
API changes
Generated by DepDelta from published Dart source. Not mixed with prose notes.
- changed:
method Firebase.operator ==(dynamic other): bool → method Firebase.operator ==(Object other): bool - changed:
method FirebaseApp.operator ==(dynamic other): bool → method FirebaseApp.operator ==(Object other): bool - changed:
static field Firebase.delegatePackingProperty: FirebasePlatform → static field Firebase.delegatePackingProperty: FirebasePlatform? - changed:
static method Firebase.initializeApp( {String name, FirebaseOptions options}): Future<FirebaseApp> → static method Firebase.initializeApp({ String? name, FirebaseOptions? options, }): Future<FirebaseApp>