Upgrading equatable 0.1 to 0.2
Breaking0.1.10 → 0.2.6Platform1New1Changed1Fixed2Other1
BreakingUpgrade verdict
A platform requirement change.
In plain terms
- This version requires Dart 2.0.0 or newer, but not Dart 3.0.0 or later.
Must act 1 item needs code or config changes
Dart SDK requirement changed in 0.2.1: >=2.0.0-dev.28.0 <3.0.0 → >=2.0.0 <3.0.0.
What you must change
Platform1
Updates the Dart SDK constraint to >=2.0.0 <3.0.0.
API changes
Generated by DepDelta from published Dart source. Not mixed with prose notes.
- added:
get EquatableMixin.hashCode: int - added:
get EquatableMixinBase.props: List - added:
method EquatableMixin.operator ==(Object other): bool - added:
method EquatableMixin.toString(): String - added:
method EquatableMixinBase.toString(): String - added:
mixin EquatableMixin on EquatableMixinBase - added:
mixin EquatableMixinBase on Object