Upgrading decimal 0.3 to 1
Breaking0.3.5 → 1.5.0Breaking1New5Changed2Other1
BreakingUpgrade verdict
1 breaking change.
In plain terms
- The package now uses Dart's null safety feature, so code that uses it must also be null safe.
Must act 1 item needs code or config changes
Dart SDK requirement changed in 1.0.0+1: >=2.0.0-dev.66.0 <3.0.0 → >=2.12.0 <3.0.0.
What you must change
Breaking1
Migrates the package to Dart null safety.