Upgrading cupertino_icons 0.1 to 1
Breaking0.1.3 → 1.0.9Breaking1Platform3New2Changed5Fixed4Other8
BreakingUpgrade verdict
1 breaking change and 3 platform requirement changes.
In plain terms
- The icon font is now complete and compatible, so the package no longer restricts which SDK version you can use.
- You now need Flutter 3.35 or Dart 3.9 or newer to use this package.
- The package now requires a newer Flutter and Dart version to use.
- You now need Flutter 3.7 or Dart 2.19 or newer to use this package.
Must act 4 items need code or config changes
Dart SDK requirement changed in 1.0.9: >=2.0.0-dev.28.0 <3.0.0 → ^3.9.0.
What you must change
Breaking1
Moves the package to 1.0.0 and removes the SDK version constraint now that font codepoints are fully compatible and missing glyphs are backfilled.
Platform3
Updates minimum supported SDK version to Flutter 3.35/Dart 3.9.
Updates minimum supported SDK version to Flutter 3.13/Dart 3.1.
Updates minimum supported SDK version to Flutter 3.7/Dart 2.19.