Upgrading coverage 0.4 to 0.5
Breaking0.4.1 → 0.5.0Breaking1Platform1New1
BreakingUpgrade verdict
1 breaking change and a platform requirement change.
In plain terms
- Removed unused package:meta dependency.
- Require Dart 3.4.
Must act 2 items need code or config changes
Dart SDK requirement changed in 0.5.0: >=1.3.0-dev.6.1 <2.0.0 → >=1.4.0 <2.0.0.
What you must change
Breaking1
Removed unused package:meta dependency.
package:metaPlatform1
Require Dart 3.4.
API changes
Generated by DepDelta from published Dart source. Not mixed with prose notes.
- removed:
function lcov(Map hitmap, IOSink output): Future - removed:
function prettyPrint(Map hitMap, List failedLoads, IOSink output): Future - changed:
field Resolver.failed: List → field Resolver.failed: final List<String> - changed:
function createHitmap(String rawJson, Resolver resolver): Map → function createHitmap(List<Map> json): Map - changed:
method Resolver.resolve(String uri) → method Resolver.resolve(String uri): String - added:
class Formatter: abstract - added:
class LcovFormatter implements Formatter - added:
class Loader - added:
class PrettyPrintFormatter implements Formatter - added:
ctor LcovFormatter(this.resolver) - added:
ctor PrettyPrintFormatter(this.resolver, this.loader) - added:
field LcovFormatter.resolver: final Resolver - added:
field Loader.failed: final List<String> - added:
field PrettyPrintFormatter.loader: final Loader - added:
field PrettyPrintFormatter.resolver: final Resolver - added:
function parseCoverage(List<File> files, int workers): Future<Map> - added:
method Formatter.format(Map json): Future<String> - added:
method LcovFormatter.format(Map hitmap): Future<String> - added:
method Loader.load(String uri): Future<List<String>> - added:
method PrettyPrintFormatter.format(Map hitmap): Future<String>