Upgrading cloud_firestore 0.3 to 0.4
Breaking0.3.2 → 0.4.0Breaking1Changed1Other1
BreakingUpgrade verdict
1 breaking change.
In plain terms
- Code that used the Firestore codec class directly can no longer access it, so it must stop relying on that internal class.
Must act 1 item needs code or config changes
Flutter requirement changed in 0.4.0: >=0.1.4 <2.0.0 → >=0.2.4 <2.0.0.
What you must change
Breaking1
Hides the Firestore codec class from the public API.
API changes
Generated by DepDelta from published Dart source. Not mixed with prose notes.
- added:
class SnapshotMetadata - added:
field SnapshotMetadata.hasPendingWrites: final bool - added:
field SnapshotMetadata.isFromCache: final bool