Skip to content

Upgrading build_web_compilers 0.4 to 1

Breaking0.4.4+3 → 1.2.3Breaking1Platform1New5Changed2Other2

BreakingUpgrade verdict

1 breaking change and a platform requirement change.

  • Removed the enable_sync_async and ignore_cast_failures options for the build_web_compilers|entrypoint builder.
  • Require Dart >=2.18.0.
2 items need code or config changes

Dart SDK requirement changed in 1.2.3: >=2.0.0 <3.0.0 → >=2.6.0 <3.0.0.

Drops pub_semver.

Moves analyzer >=0.30.0 <0.35.0 → >=0.30.0 <0.37.0, bazel_worker ^0.1.4 → ^0.1.18, build_config >=0.2.6 <0.4.0 → >=0.2.6 <0.5.0. Your build may pick other versions.

Breaking1
Removed the enable_sync_async and ignore_cast_failures options for the build_web_compilers|entrypoint builder.
enable_sync_asyncignore_cast_failuresbuild_web_compilers|entrypoint
Platform1
Require Dart >=2.18.0.

Generated by DepDelta from published Dart source. Not mixed with prose notes.

  • removed: field WebEntrypointBuilder.enableSyncAsync: final bool
  • removed: field WebEntrypointBuilder.ignoreCastFailures: final bool
  • changed: ctor WebEntrypointBuilder(this.webCompiler, {this.dart2JsArgs = …, this.useKernel = …, this.buildRootAppSummary = …, this.ignoreCastFailures = …, this.enableSyncAsync = …}) → ctor WebEntrypointBuilder(this.webCompiler, {this.dart2JsArgs = …, this.useKernel = …, this.buildRootAppSummary = …})