Skip to content

Upgrading analyzer_plugin 0.12 to 0.13

Breaking0.12.0 → 0.13.11Breaking3Platform1Deprecated1New1Changed11

BreakingUpgrade verdict

3 breaking changes and a platform requirement change.

  • A helper method for naming code elements has been removed; use the replacement method.
  • Code that uses the edit builder classes may need updates to keep compiling.
  • Code that uses the analyzer converter may need updates to keep compiling.
  • You need Dart 3.9.0 or newer to use this version.
5 items need code or config changes

Dart SDK requirement changed in 0.13.8: ^3.0.0 → ^3.9.0.

Drops meta.

Moves analyzer ^7.0.0 → 9.0.0, dart_style >=2.3.7 <4.0.0 → ^3.0.0. Your build may pick other versions.

Breaking3
Removes elementName() from RangeFactory; use fragmentName() instead.
RangeFactoryelementName()fragmentName()
Introduces breaking changes to DartFileEditBuilder and DartEditBuilder.
DartFileEditBuilderDartEditBuilder
Introduces breaking changes to AnalyzerConverter.
AnalyzerConverter
Platform1
Requires Dart SDK ^3.9.0.
Deprecated1
Deprecates RangeFactory.error in favor of RangeFactory.diagnostic.
RangeFactory.errorRangeFactory.diagnostic