Skip to content

Upgrading Amazon.JSII.Runtime 0.22 to 1

Breaking0.22.0 → 1.142.0Breaking12Security1Platform6Deprecated2New139Changed50Fixed385Other39

BreakingUpgrade verdict

12 breaking changes and 6 platform requirement changes and a security fix.

  • If you use this package with .NET, it no longer works on the old netcoreapp3.1 runtime. Move your app to .NET 6 or .NET 7.
  • This version no longer works on Node.js 12. You need to upgrade to Node.js 14, 16, or 18.
  • Drops support for Node 12.
  • Python 3.6 is no longer supported because it is no longer maintained.
Top 5 of 21 that need code or config changes

Target frameworks requirement changed in 1.115.0: .NETCoreApp3.0 → net6.0.

Drops amazon.jsii.jsonmodel.

Moves microsoft.extensions.dependencyinjection 3.1.1 → 9.0.1, microsoft.extensions.logging 3.1.1 → 9.0.1, microsoft.extensions.logging.console 3.1.1 → 9.0.1, newtonsoft.json 12.0.3 → 13.0.3. Your build may pick other versions.

Breaking12
The .NET runtime library and generated .NET bindings no longer support netcoreapp3.1; users should upgrade to net6.0 or net7.0.
Drops support for Node 12; users must migrate to Node 14.x, 16.x, or 18.x.
Drops support for Node 12.
Drops support for Python 3.6, which reached end of life on 2021-12-23.
The jsii/superchain Docker image no longer includes ruby and gcc; users who need them must install them in their initialization script.
jsii/superchain
Requires Python 3.10+ in modules and updates runtime dependencies.
jsii-pacmak now has a peer dependency on jsii-rosetta, requiring a matching version to be available.
jsii-pacmakjsii-rosetta
jsii-pacmak and generated Python libraries now require Python 3.8 instead of 3.7.
jsii-pacmak
All libraries and tools now require Node.js 18 instead of Node.js 16.
jsii-pacmak and generated Python libraries now require Python 3.7 or later, dropping Python 3.6 support.
jsii-pacmak
Stops maintaining the jsii/superchain image tags :latest, :nightly, :node10 and :node14; users should move to debian-based tags starting with :1-buster-slim.
jsii/superchain
Members with the same name but different capitalization may only have one non-deprecated variant.
Security1
Fixes a shell injection vulnerability in the jsii-diff npm: argument type.
jsii-diffnpm:
Platform6
Bumps the minimum required Go version to 1.26.
Drops Python 3.9 support and requires Python 3.10 or later, since Python 3.9 reached end-of-life in October 2025.
python_requirespyrightpythonVersion
Drops Python 3.9 support and requires Python >= 3.10.
Raises the minimum supported Node.js version from 10.3.0 to 12.7.0, with 16.x recommended.
Upgrades the baseline Node.js requirement to >=12.7.0.
Requires Go 1.16 and uses native embed.
Deprecated2
Deprecates the jsii/superchain:buster-slim-* images.
jsii/superchain:buster-slim-*
Shows a deprecation message when using Python 3.7 or earlier.