Upgrading react-native 0.62 to 0.63
Breaking0.62.3 → 0.63.5Platform2New6Changed1Fixed1
BreakingUpgrade verdict
2 platform requirement changes.
In plain terms
- Apps can no longer target iOS 9; a newer minimum iOS version is required.
- Developers must use Node.js version 10 or newer to build React Native apps.
Must act 2 items need code or config changes
react-native publishes official migration guides for versions 0.63, 0.63. They cover more than the release notes do.
Upgrade helper webtool ↗Upgrade Support ↗Node.js requirement changed in 0.63.0-rc.0: >=8.3 → >=10.
Drops connect, create-react-class, escape-string-regexp, eslint-plugin-relay.
Installs 731 packages in all (was 749).
What you must change
Platform2
Drops iOS 9 support.
Drops Node.js 8 support; Node.js 10 or later is now required.