Upgrading prettier-plugin-tailwindcss 0.6 to 0.7
Breaking0.6.14 → 0.7.4Breaking1New6Changed6Fixed6
BreakingUpgrade verdict
1 breaking change.
In plain terms
- The plugin no longer works together with prettier-plugin-import-sort.
Must act 1 item needs code or config changes
Node.js requirement changed in 0.7.0: >=14.21.3 → >=20.19.
What you must change
Breaking1
Drops support for
prettier-plugin-import-sort.prettier-plugin-import-sortAPI changes
Generated by DepDelta from published .d.ts files. Not mixed with prose notes.
- removed:
interface ParserOptions extends PluginOptions - removed:
interface RequiredOptions extends PluginOptions
- removed:
declare module 'prettier'