Skip to content

Upgrading prettier-plugin-tailwindcss 0.4 to 0.5

Breaking0.4.1 → 0.5.14Platform1New5Changed3Fixed11

BreakingUpgrade verdict

A platform requirement change.

  • This version changes which versions of Prettier it declares compatible, so check that your installed Prettier satisfies the new peer dependency range.
1 item needs code or config changes

Node.js requirement changed in 0.5.0: >=12.17.0 → >=14.21.3.

Platform1
Updates the Prettier peer dependency range.

Generated by DepDelta from published .d.ts files. Not mixed with prose notes.

  • changed: property PluginOptions.tailwindAttributes: string[] → property PluginOptions.tailwindAttributes?: string[]
  • changed: property PluginOptions.tailwindFunctions: string[] → property PluginOptions.tailwindFunctions?: string[]
  • added: property PluginOptions.tailwindEntryPoint?: string