Upgrading karma-jasmine 4 to 5
Breaking4.0.2 → 5.1.0Breaking3Platform1New2Fixed2
BreakingUpgrade verdict
3 breaking changes and a platform requirement change.
In plain terms
- The minimum required version of karma is 6.0.0.
- The minimum required version of Node is 12.0.0.
- deps: jasmine-core was updated to the 4.1.0.
- Drop Node.js 10 support.
Must act 4 items need code or config changes
Node.js requirement changed in 5.0.0: >= 10 → >=12.
What you must change
Breaking3
The minimum required version of karma is 6.0.0.
The minimum required version of Node is 12.0.0.
deps: jasmine-core was updated to the 4.1.0.
Platform1
Drop Node.js 10 support.