Upgrading js-yaml 0.2 to 0.3
Breaking0.2.2 → 0.3.7Breaking2New6Changed2Fixed14Other4
BreakingUpgrade verdict
2 breaking changes.
In plain terms
- The package no longer includes its AMD module support, so AMD-based loaders will not find it.
- The library no longer relies on JS.Class, so code depending on that integration may need changes.
Must act 2 items need code or config changes
Node.js requirement changed in 0.3.2: > 0.4.11 < 0.7.0 → > 0.4.11.
Drops jsclass.
Installs 0 packages in all (was 3).
No longer installs abbrev, nopt.
What you must change
Breaking2
Removes the AMD support parts because they were too buggy to use.
Removes the JS.Class dependency.
JS.Class