Skip to content

Upgrading gulp-babel 6 to 7

Breaking6.1.3 → 7.0.1Breaking2Platform1Other3

BreakingUpgrade verdict

2 breaking changes and a platform requirement change.

  • You now need to install babel-core yourself; the package no longer bundles it. It works with babel-core v6 and v7 pre-releases.
  • This version now requires the newer Babel 7 beta core package, so older Babel 6 setups will not work with it.
  • The package no longer works on very old versions of Node.js (0.10 and 0.12).
3 items need code or config changes

Node.js requirement changed in 7.0.0-alpha.18: >=0.10.0 → >=4.

Drops babel-core, object-assign.

Installs 23 packages in all (was 73).

Breaking2
Makes babel-core a peerDependency instead of a dependency, supporting v6 and v7 (alpha/beta/rc).
babel-core
Updates to babel-core@7.0.0-beta.18, which is a breaking change.
babel-core
Platform1
Drops support for Node 0.10 and 0.12.