Skip to content

Upgrading @typescript-eslint/eslint-plugin 0.2 to 1

Breaking0.2.1 → 1.13.0Breaking1Platform2New37Changed7Fixed70Other3

BreakingUpgrade verdict

1 breaking change and 2 platform requirement changes.

  • The ESLint plugin no longer bundles or exports the TypeScript parser; install the parser package separately.
  • The package now declares which major versions of its peer dependency it accepts, so installs pick a compatible version.
  • You need TypeScript 3.2.1 or newer, but below 3.6.0, to use this version.
3 items need code or config changes

Node.js requirement changed in 1.1.1-alpha.7: >=6 → ^6.14.0 || ^8.10.0 || >=9.10.0.

Adds @typescript-eslint/experimental-utils 1.13.0, eslint-utils ^1.3.1, functional-red-black-tree ^1.0.1, regexpp ^2.0.1, tsutils ^3.7.0.

Drops @typescript-eslint/parser, requireindex.

Installs 15 packages in all (was 10).

Breaking1
Removes the parser exported from the eslint plugin.
Platform2
The eslint-plugin peer dependency now specifies a semver major range.
Supports TypeScript versions >=3.2.1 <3.6.0.