Upgrading yoast/phpunit-polyfills 0.2 to 1
Breaking0.2.0 → 1.1.5Breaking2Platform1New6Changed1Fixed7Other26
BreakingUpgrade verdict
2 breaking changes and a platform requirement change.
In plain terms
- One of the package's internal classes can no longer be subclassed. Most users will not notice.
- Code that called these fixture setup and teardown methods from outside the test case class will no longer work.
- The package can now be installed on PHP 5.4, one version older than before.
Must act 3 items need code or config changes
PHP requirement changed in 1.0.0: >=5.5 → >=5.4.
What you must change
Breaking2
The
Yoast\PHPUnitPolyfills\Autoload class is now final, so it can no longer be extended.Yoast\PHPUnitPolyfills\AutoloadChanges XTestCase::setUpFixtures() and XTestCase::tearDownFixtures() visibility from public to protected.
XTestCasesetUpFixtures()tearDownFixtures()Platform1
Lowers the minimum supported PHP version to PHP 5.4 (was 5.5).
API changes
Generated by DepDelta from published PHP source. Not mixed with prose notes.
- changed:
class Autoload → final class Autoload - changed:
static method Autoload.load($class) → static method Autoload.load($className) - added:
const Autoload.VERSION - added:
static method Autoload.getPHPUnitVersion() - added:
static method Autoload.loadAssertClosedResource() - added:
static method Autoload.loadAssertObjectEquals() - added:
static method Autoload.loadAssertObjectProperty() - added:
static method Autoload.loadEqualToSpecializations()