Upgrading pretty_assertions 0.7 to 1
Breaking0.7.2 → 1.4.1Breaking1Platform1New4Changed3Fixed5Other1
BreakingUpgrade verdict
1 breaking change and a platform requirement change.
In plain terms
- Code that used the library's re-exported Style type will no longer compile.
- This version of the library now requires Rust 1.54.0 or newer to compile.
Must act 2 items need code or config changes
Adds yansi ^1.0.1.
Drops ansi_term, ctor, output_vt100.
Installs 2 packages in all (was 11).
What you must change
Breaking1
Removes the publicly re-exported
ansi_term::Style, which was never intended for public use.ansi_term::StylePlatform1
Raises the minimum supported Rust version (MSRV) to 1.54.0.