Upgrading itertools 0.9 to 0.10
Breaking0.9.0 → 0.10.5Platform1Deprecated4New33Changed2Other5
BreakingUpgrade verdict
A platform requirement change.
In plain terms
- This version of the library now requires Rust 1.32.0 or newer to compile.
- Deprecates `Itertools::fold_results`, use `Itertools::fold_ok` instead.
- Deprecates `Itertools::map_results`, use `Itertools::map_ok` instead.
- Deprecates `FoldResults`, use `FoldOk` instead.
Must act Top 4 of 5 that need code or config changes
Adds paste ^1.0.0.
Installs 58 packages in all (was 59).
What you must change
Platform1
Increases the minimum supported Rust version to 1.32.0.
Deprecations to plan for
Deprecated4
Deprecates
Itertools::fold_results, use Itertools::fold_ok instead.Itertools::fold_resultsItertools::fold_okDeprecates
Itertools::map_results, use Itertools::map_ok instead.Itertools::map_resultsItertools::map_okDeprecates
FoldResults, use FoldOk instead.FoldResultsFoldOkDeprecates
MapResults, use MapOk instead.MapResultsMapOk