Skip to content

Upgrading derive_more 0.15 to 0.99

Breaking0.15.0 → 0.99.20Breaking2Platform2New11Changed6Fixed5Other3

BreakingUpgrade verdict

2 breaking changes and 2 platform requirement changes.

  • You no longer need to enable a feature to use this library without the standard library.
  • If your project uses the older Rust 2015 edition, you must add a line declaring the core crate.
  • The minimum supported Rust version (MSRV) is now Rust 1.65.
  • You now need Rust 1.36 or newer to use this library.
4 items need code or config changes

Adds convert_case ^0.4, peg ^0.5.

Drops lazy_static, regex.

Installs 9 packages in all (was 12).

Breaking2
Removes the no_std feature; no_std now works without configuring features.
no_std
Requires extern crate core when used in a Rust 2015 crate.
core
Platform2
The minimum supported Rust version (MSRV) is now Rust 1.65.
Raises the minimum supported Rust version (MSRV) to Rust 1.36.