Upgrading backtrace 0.2 to 0.3
Breaking0.2.3 → 0.3.77Breaking4Platform1New6Changed16Fixed10Other13
Fetching 78 releases from GitHub…6 / 78
BreakingUpgrade verdict
4 breaking changes and a platform requirement change.
In plain terms
- Some old, non-functional feature flags are gone, so projects that enable them will not be upgraded to this version automatically.
- Removes the unused libbacktrace and gimli-symbolize features.
- Android backtraces get much better on devices with a recent enough API level, but older Android versions are no longer supported.
- Code that exhaustively matched on PrintFmt will no longer compile and must add a wildcard arm.
Must act Top 4 of 5 that need code or config changes
Requires Rust 1.88.0 from 0.3.77 (none stated before).
Adds addr2line ^0.27.0, cpp_demangle ^0.5.0, libloading ^0.9, miniz_oxide ^0.9, object ^0.40.0, ruzstd ^0.9.1, windows-link ^0.2.
Drops backtrace-sys, dbghelp-sys, kernel32-sys, rustc-serialize, serde_codegen, winapi.
Installs 19 packages in all (was 27).
What you must change
Breaking4
Removes feature flags that have not done anything in a long time; Cargo's resolver will not update dependents of those features to 0.3.72.
Removes the unused libbacktrace and gimli-symbolize features.
libbacktracegimli-symbolizeCleans up Android support, improving backtraces on newer API levels but dropping support for older ones.
Makes PrintFmt use #[non_exhaustive] instead of the Enum::__NonExhaustiveVariant pattern.
PrintFmtEnum::__NonExhaustiveVariantPlatform1
Raises the minimum supported Rust version (MSRV) to 1.79.