Skip to content

Utilities

General-purpose helpers, collections and functional tools. 147 packages across 9 ecosystems.

Mcom.google.guava:guavaGuava is a suite of core and expanded libraries that include utility classes, Google's collections, I/O classes, and much more.33.7.2-jreSep 29, 2026Apache-2.0Mcom.google.guava:failureaccessContains com.google.common.util.concurrent.internal.InternalFutureFailureAccess and InternalFutures. Most users will never need to use this artifact. Its classes are conceptually a part of Guava, but they're in this separate artifact so that Android libraries can use them without pulling in all of Guava (just as they can use ListenableFuture by depending on the listenablefuture artifact).1.0.3Mar 19, 2025Apache-2.0Morg.scala-lang:scala-reflectReflection Library for the Scala Programming Language2.13.18Nov 17, 2025Apache-2.0Morg.scala-lang:scala3-library_3scala3-library-bootstrapped3.10.0Oct 5, 2026Apache-2.0Morg.scala-lang:scala3-library_sjs1_3scala3-library-sjs3.10.0Oct 5, 2026Apache-2.0Morg.scala-lang:scala-compilerCompiler for the Scala Programming Language2.13.18Nov 17, 2025Apache-2.0Morg.scala-lang:scala-libraryscala-library-bootstrapped3.10.0Oct 5, 2026Apache-2.0Morg.codehaus.groovy:groovyGroovy: A powerful, dynamic language for the JVM3.0.25May 27, 2025Apache-2.0Morg.codehaus.groovy:groovy-allGroovy: A powerful, dynamic language for the JVM3.0.25May 27, 2025Apache-2.0Mcommons-codec:commons-codecThe Apache Commons Codec component contains encoders and decoders for formats such as Base16, Base32, Base64, digest, and Hexadecimal. In addition to these widely used encoders and decoders, the codec package also maintains a collection of phonetic encoding utilities.1.23.0Oct 12, 2026Mcom.fasterxml.jackson.datatype:jackson-datatype-guavaAdd-on datatype-support module for Jackson (https://github.com/FasterXML/jackson) that handles Guava (https://github.com/google/guava) types (currently mostly just collection ones)2.22.4Oct 17, 2026Apache-2.0Morg.codehaus.plexus:plexus-utilsA collection of various utility classes to ease working with strings, files, command lines and more.4.1.0Aug 19, 2026Apache-2.0Mcommons-httpclient:commons-httpclientThe HttpClient component supports the client-side of RFC 1945 (HTTP/1.0) and RFC 2616 (HTTP/1.1) , several related specifications (RFC 2109 (Cookies) , RFC 2617 (HTTP Authentication) , etc.), and provides a framework by which new request types (methods) or HTTP extensions can be created easily.3.1Aug 21, 2007Apache LicenseMorg.apache.commons:commons-pool2The Apache Commons Object Pooling Library.2.13.1Dec 30, 2025Apache-2.0Morg.apache.commons:commons-math3The Apache Commons Math project is a library of lightweight, self-contained mathematics and statistics components addressing the most common practical problems not immediately available in the Java programming language or commons-lang.3.6.1Mar 17, 2016Apache-2.0Mcommons-configuration:commons-configurationTools to assist in the reading of configuration/preferences files in various formats.1.10Oct 24, 2013Apache-2.0Mcommons-dbcp:commons-dbcpCommons Database Connection Pooling1.4Feb 7, 2010Apache-2.0Morg.apache.commons:commons-textApache Commons Text is a set of utility functions and reusable components for processing and manipulating text in a Java environment.1.15.0Dec 4, 2025Apache-2.0Mcommons-validator:commons-validatorApache Commons Validator provides the building blocks for both client-side and server-side data validation. It may be used standalone or with a framework like Struts.1.11.0Jul 31, 2026Apache-2.0Morg.apache.commons:commons-collections4The Apache Commons Collections package contains types that extend and augment the Java Collections Framework.4.6.0Aug 6, 2026Apache-2.0